Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Dec 13, 2025 - 06:00 UTC
Scheduled
We will be performing maintenance on US Mediasite Video Cloud during our scheduled maintenance window on December 13, between 12:00 AM and 4:00 AMCST. Extended downtime is not expected, but there may be periods of interruption to live streaming during this time.
Posted Dec 12, 2025 - 20:27 UTC
This scheduled maintenance affected: US Mediasite Video Cloud (Live Streaming).