Mediasite Video Cloud Incident - Authentication Redirects

Incident Report for Mediasite

Resolved

After applying the 8.52.1 hotfix, we have seen no occurrence of these issues and the environment is currently functioning normally.
Posted May 06, 2026 - 15:07 UTC

Investigating

We are aware of issues within the Mediasite Video Cloud environment regarding SAML/SSO authentication, and are investigating. Some users may experience URL redirects after authenticating when accessing Mediasite content.
Posted May 05, 2026 - 17:31 UTC
This incident affected: US Mediasite Video Cloud (Management Portal / My Mediasite, On Demand Playback, Authentication) and EU Mediasite Video Cloud (Management Portal / My Mediasite, On Demand Playback, Authentication).