Mediasite Cloud Issues

Incident Report for Mediasite

Resolved

We have seen no occurrence of these issues over the past hour and the environment is currently functioning normally.
Posted Feb 12, 2026 - 22:40 UTC

Monitoring

Mitigation steps have been taken, and we continue to monitor the situation.
Posted Feb 12, 2026 - 21:01 UTC

Investigating

Some users may experience intermittent errors and slowness when accessing Mediasite Video Cloud.
Posted Feb 12, 2026 - 18:52 UTC
This incident affected: US Mediasite Video Cloud (Management Portal / My Mediasite).