Mediasite Video Cloud Incident - Video Playback

Incident Report for Mediasite

Resolved

We have seen no occurrence of the issue over the past several hours and playback is currently functioning normally.
Posted Sep 03, 2025 - 02:50 UTC

Monitoring

Mitigation steps have been taken, and we continue to monitor the situation.
Posted Sep 02, 2025 - 21:40 UTC

Identified

We are aware of issues impacting video playback in the Video Cloud environment and are working towards resolution. More information will be provided when possible.
Posted Sep 02, 2025 - 21:04 UTC
This incident affected: US Mediasite Video Cloud (On Demand Playback).