Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 28, 2025 - 23:00 UTC
Scheduled
We will be updating Mediasite Capture to the latest release during our scheduled maintenance window on 28 March, between 6:00 PM and 10:00 PM CDT. Extended downtime is not expected. However, your content creators may be unable to record with Mediasite Capture during the maintenance window.
Posted Mar 14, 2025 - 14:53 UTC
This scheduled maintenance affected: Mediasite Capture.